add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Need Help - Alienware X51 (Can't Boot past Logo Screen)

RBRaindrop

1 month ago

Computer turns on and powers up. Computer gets to logo screen and shows F2 Setup or F12 Boot Options. I can't get it to do either however when I select these.

I cleared CMOS but still no success. Anyone have any idea where to start. My guess is a corrupted Bios, but not sure how to restore if I cannot boot past logo screen.

Comments

  • 1 month ago
  • 1 point

Is this a new computer or one that was running OK until now. If new exchanging it for a working model is probably the easiest way to go. If you have been using it for a while, your boot drive may have gone bad.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube